Software Requirements

The Focals app is compatible with Android smartphones running Android OS 5.0+ or iPhones (5S or newer) running iOS 11+. 

For more device information and specifications, find what you're looking for in our Important Information Guide.

Was this article helpful?

23 out of 23 found this helpful